ERROR connecting to squid proxy server

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

ERROR connecting to squid proxy server

Reshma V Kumar
Hi all,
 
I am testing squid 4.13 on AIX 7.2. I started the squid proxy server in the foreground using the following command
 
/opt/freeware/sbin/squid_32 -f /opt/freeware/etc/squid/squid.conf -d3 --foreground
 
To test if the squid proxy server is working or not, the following curl command is run which always give Service Unavailable error
$ curl -x http://x.xx.xx.xxx:3128 -I http://www.google.com
HTTP/1.1 503 Service Unavailable
Server: squid/4.13
Mime-Version: 1.0
Date: Tue, 01 Dec 2020 06:26:43 GMT
Content-Type: text/html;charset=utf-8
Content-Length: 3698
X-Squid-Error: ERR_DNS_FAIL 0
Vary: Accept-Language
Content-Language: en
X-Cache: MISS from fvt-p7a2-lp17.pok.stglabs.ibm.com
Via: 1.1 fvt-p7a2-lp17.pok.stglabs.ibm.com (squid/4.13)
Connection: keep-alive
 
I have attached the output of the squid command running in foreground.
Any idea why this is happening?
 
Thanks & Regards
 
RESHMA KUMAR
Associate system engineer( AIX Opensource)
Phone: 91-733-862-7032


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users

squid_output.txt (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: ERROR connecting to squid proxy server

Amos Jeffries
Administrator
On 1/12/20 8:20 pm, Reshma V Kumar wrote:
> Hi all,
> I am testing squid 4.13 on AIX 7.2. I started the squid proxy server in
> the foreground using the following command
> */opt/freeware/sbin/squid_32 -f /opt/freeware/etc/squid/squid.conf -d3
> --foreground*
> To test if the squid proxy server is working or not, the following curl
> command is run which always give Service Unavailable error

> *$ curl -x http://x.xx.xx.xxx:3128 <http://9.47.64.198:3128> -I
> http://www.google.com <http://www.google.com>
> HTTP/1.1 503 Service Unavailable
> Server: squid/4.13
> Mime-Version: 1.0
> Date: Tue, 01 Dec 2020 06:26:43 GMT
> Content-Type: text/html;charset=utf-8
> Content-Length: 3698
> X-Squid-Error: ERR_DNS_FAIL 0
> Vary: Accept-Language
> Content-Language: en
> X-Cache: MISS from fvt-p7a2-lp17.pok.stglabs.ibm.com
> Via: 1.1 fvt-p7a2-lp17.pok.stglabs.ibm.com (squid/4.13)
> Connection: keep-alive*

> I have attached the output of the squid command running in foreground.
> Any idea why this is happening?

The error message tells you what is going wrong. It says: DNS Failure.

The cache.log should contain more details about which DNS server(s)
failed and where the DNS server details came from.


Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: ERROR connecting to squid proxy server

Reshma V Kumar
Hi !
 
This is the error from cache.log file
 
2021/01/11 23:21:07 kid1| idnsSendQuery FD -1: sendto: (0) No error.
 
and following error in access.log file
TCP_MISS/503 384 HEAD http://www/google.com - HIER_NONE/- text/html
 
Any thoughts?
 
Thanks&Regards,
Reshma
 
 
----- Original message -----
From: Amos Jeffries <[hidden email]>
Sent by: "squid-users" <[hidden email]>
To: [hidden email]
Cc:
Subject: [EXTERNAL] Re: [squid-users] ERROR connecting to squid proxy server
Date: Tue, Dec 1, 2020 5:32 PM
 
On 1/12/20 8:20 pm, Reshma V Kumar wrote:
> Hi all,
> I am testing squid 4.13 on AIX 7.2. I started the squid proxy server in
> the foreground using the following command
> */opt/freeware/sbin/squid_32 -f /opt/freeware/etc/squid/squid.conf -d3
> --foreground*
> To test if the squid proxy server is working or not, the following curl
> command is run which always give Service Unavailable error

> *$ curl -x http://x.xx.xx.xxx:3128  <http://9.47.64.198:3128 > -I
> http://www.google.com  <http://www.google.com >
> HTTP/1.1 503 Service Unavailable
> Server: squid/4.13
> Mime-Version: 1.0
> Date: Tue, 01 Dec 2020 06:26:43 GMT
> Content-Type: text/html;charset=utf-8
> Content-Length: 3698
> X-Squid-Error: ERR_DNS_FAIL 0
> Vary: Accept-Language
> Content-Language: en
> X-Cache: MISS from fvt-p7a2-lp17.pok.stglabs.ibm.com
> Via: 1.1 fvt-p7a2-lp17.pok.stglabs.ibm.com (squid/4.13)
> Connection: keep-alive*

> I have attached the output of the squid command running in foreground.
> Any idea why this is happening?

The error message tells you what is going wrong. It says: DNS Failure.

The cache.log should contain more details about which DNS server(s)
failed and where the DNS server details came from.


Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users 

 
 


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: ERROR connecting to squid proxy server

Amos Jeffries
Administrator
On 12/01/21 6:30 pm, Reshma V Kumar wrote:
> Hi !
> This is the error from cache.log file
> 2021/01/11 23:21:07 kid1| idnsSendQuery FD -1: sendto: (0) No error.


  "-1" is a closed socket. It looks like there is no UDP port open for
sending traffic to your DNS server(s).

You are starting Squid with root privileges right?

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users