Errors Compiling Squid Proxy on Windows using Cygwin

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Errors Compiling Squid Proxy on Windows using Cygwin

Russel McDonald

Hi,

 I’ve followed the small set of steps for building squid proxy using Cygwin on Windows 7 but am getting compile time errors. Specifically the below. Sorry for emailing this question if this has been answered. I searched past emails and the most recent hit on errors building on Windows was from 2010.

 

Cygwin version 2.11.2 from Nov 8/2018 and installed ALL features including devel.

Downloaded squid source, tar –xvf  squid-3.5.11.tar.gz (I tried version 3.5.28 as well)

./configure --bindir=/bin/squid --sbindir=/usr/sbin/squid --sysconfdir=/etc/squid    --datadir=/usr/share/squid --libexecdir=/usr/lib/squid --disable-strict-error-checking    --with-logdir=/var/log/squid --with-swapdir=/var/cache/squid

And tried with --enable-win32-service as well.

 

Then make produces the error below. What am I doing incorrectly?

 ….

….

In file included from /usr/include/w32api/lm.h:18:0,

                 from ext_lm_group_acl.cc:96:

/usr/include/w32api/lmserver.h:30:33: error: `SERVICE_STATUS_HANDLE' was not dec

lared in this scope

   WINBOOL WINAPI SetServiceBits(SERVICE_STATUS_HANDLE hServiceStatus,DWORD dwSe

rviceBits,WINBOOL bSetBitsOn,WINBOOL bUpdateImmediately);

                                 ^~~~~~~~~~~~~~~~~~~~~

/usr/include/w32api/lmserver.h:30:33: note: suggested alternative: `SERVICE_PAUS

ABLE'

   WINBOOL WINAPI SetServiceBits(SERVICE_STATUS_HANDLE hServiceStatus,DWORD dwSe

rviceBits,WINBOOL bSetBitsOn,WINBOOL bUpdateImmediately);

                                 ^~~~~~~~~~~~~~~~~~~~~

                                 SERVICE_PAUSABLE

/usr/include/w32api/lmserver.h:30:76: error: expected primary-expression before

`dwServiceBits'

   WINBOOL WINAPI SetServiceBits(SERVICE_STATUS_HANDLE hServiceStatus,DWORD dwSe

rviceBits,WINBOOL bSetBitsOn,WINBOOL bUpdateImmediately);

                                                                            ^~~~

~~~~~~~~~

/usr/include/w32api/lmserver.h:30:98: error: expected primary-expression before

`bSetBitsOn'

   WINBOOL WINAPI SetServiceBits(SERVICE_STATUS_HANDLE hServiceStatus,DWORD dwSe

rviceBits,WINBOOL bSetBitsOn,WINBOOL bUpdateImmediately);

 

                  ^~~~~~~~~~

/usr/include/w32api/lmserver.h:30:117: error: expected primary-expression before

`bUpdateImmediately'

   WINBOOL WINAPI SetServiceBits(SERVICE_STATUS_HANDLE hServiceStatus,DWORD dwSe

rviceBits,WINBOOL bSetBitsOn,WINBOOL bUpdateImmediately);

 

                                     ^~~~~~~~~~~~~~~~~~

/usr/include/w32api/lmserver.h:30:135: error: expression list treated as compoun

d expression in initializer [-fpermissive]

   WINBOOL WINAPI SetServiceBits(SERVICE_STATUS_HANDLE hServiceStatus,DWORD dwSe

rviceBits,WINBOOL bSetBitsOn,WINBOOL bUpdateImmediately);

Thanks!

Russel McDonald

 

 


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Errors Compiling Squid Proxy on Windows using Cygwin

Amos Jeffries
Administrator
On 15/12/18 8:52 am, Russel McDonald wrote:

> Hi,
>
>  I’ve followed the small set of steps for building squid proxy using
> Cygwin on Windows 7 but am getting compile time errors. Specifically the
> below. Sorry for emailing this question if this has been answered. I
> searched past emails and the most recent hit on errors building on
> Windows was from 2010.
>
>  
>
> Cygwin version 2.11.2 from Nov 8/2018 and installed ALL features
> including devel.
>
> Downloaded squid source, tar –xvf  squid-3.5.11.tar.gz (I tried version
> 3.5.28 as well)
>
> ./configure --bindir=/bin/squid --sbindir=/usr/sbin/squid
> --sysconfdir=/etc/squid    --datadir=/usr/share/squid
> --libexecdir=/usr/lib/squid --disable-strict-error-checking   
> --with-logdir=/var/log/squid --with-swapdir=/var/cache/squid
>
> And tried with --enable-win32-service as well.
>
>  
>
> Then make produces the error below. What am I doing incorrectly?
>

Your Squid is detecting the existence of Windows OS headers and trying
to build a helper which has bugs in your environment.

This type of problem is why the Diladele Cygwin instructions (and other
OS cross-building) list the helpers to build explicitly whereas native
builds can just use the auto-detect by ./configure. Doing the same for
your build will both avoid this issue and reduce the size of your Squid
build.


Please open a bug report in our bugzilla about this so it does not get
forgotten. I am not aware of anyone working on Windows bugs right now so
no ETA on when it might get fixed.

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Errors Compiling Squid Proxy on Windows using Cygwin

Rafael Akchurin
Hello Russel, Amos, all list members,

The 3.5 compilation instructions are at https://docs.diladele.com/howtos/build_squid_windows/index.html
And we are still planning to allocate task forces to compile Squid 4 for Cygwin after initial failures ☹

@Russel - see our project at - fork it if you have patches/improvements! At https://github.com/diladele/squid-windows

Best regards,
Rafael Akchurin
Diladele B.V.

-----Original Message-----
From: squid-users <[hidden email]> On Behalf Of Amos Jeffries
Sent: Monday, 17 December 2018 02:37
To: [hidden email]
Subject: Re: [squid-users] Errors Compiling Squid Proxy on Windows using Cygwin

On 15/12/18 8:52 am, Russel McDonald wrote:

> Hi,
>
>  I’ve followed the small set of steps for building squid proxy using
> Cygwin on Windows 7 but am getting compile time errors. Specifically
> the below. Sorry for emailing this question if this has been answered.
> I searched past emails and the most recent hit on errors building on
> Windows was from 2010.
>
>  
>
> Cygwin version 2.11.2 from Nov 8/2018 and installed ALL features
> including devel.
>
> Downloaded squid source, tar –xvf  squid-3.5.11.tar.gz (I tried
> version
> 3.5.28 as well)
>
> ./configure --bindir=/bin/squid --sbindir=/usr/sbin/squid
> --sysconfdir=/etc/squid    --datadir=/usr/share/squid
> --libexecdir=/usr/lib/squid --disable-strict-error-checking
> --with-logdir=/var/log/squid --with-swapdir=/var/cache/squid
>
> And tried with --enable-win32-service as well.
>
>  
>
> Then make produces the error below. What am I doing incorrectly?
>

Your Squid is detecting the existence of Windows OS headers and trying to build a helper which has bugs in your environment.

This type of problem is why the Diladele Cygwin instructions (and other OS cross-building) list the helpers to build explicitly whereas native builds can just use the auto-detect by ./configure. Doing the same for your build will both avoid this issue and reduce the size of your Squid build.


Please open a bug report in our bugzilla about this so it does not get forgotten. I am not aware of anyone working on Windows bugs right now so no ETA on when it might get fixed.

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users