Invalid URL when trying to access cachemgr

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Invalid URL when trying to access cachemgr

Scott
Hi all,

I have three squid proxies, two of which respond normally to cachemgr
requests:

# printf "GET cache_object://localhost/info HTTP/1.0\r\n\r\n" | nc HOSTNAME
3128

The third proxy however returns an html error page:

        <body id=ERR_INVALID_URL>
        <div id="titles">
        <h1>ERROR</h1>
        <h2>The requested URL could not be retrieved</h2>
        </div>
        <hr>

        <div id="content">
        <p>The following error was encountered while trying to retrieve the
        URL: <a
        href="cache_object://localhost/info">cache_object://localhost/info</a></p>

I have tried replacing `localhost' with the visible_hostname to no avail.

Does anyone have any clues as to why this may be?

Thanks,
Scott
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Invalid URL when trying to access cachemgr

Amos Jeffries
Administrator
On 29/02/20 4:11 pm, Scott wrote:

> Hi all,
>
> I have three squid proxies, two of which respond normally to cachemgr
> requests:
>
> # printf "GET cache_object://localhost/info HTTP/1.0\r\n\r\n" | nc HOSTNAME
> 3128
>
> The third proxy however returns an html error page:
>

Which Squid version is this one?


Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Invalid URL when trying to access cachemgr

Scott
In reply to this post by Scott
> Date: Mon, 2 Mar 2020 01:18:58 +1300
> From: Amos Jeffries <[hidden email]>
> To: [hidden email]
> Subject: Re: [squid-users] Invalid URL when trying to access cachemgr
>
> On 29/02/20 4:11 pm, Scott wrote:
> > Hi all,
> >
> > I have three squid proxies, two of which respond normally to cachemgr
> > requests:
> >
> > # printf "GET cache_object://localhost/info HTTP/1.0\r\n\r\n" | nc HOSTNAME
> > 3128
> >
> > The third proxy however returns an html error page:
> >
>
> Which Squid version is this one?
>
All three are running 4.9

Scott
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users