Problem webpagge filter - acl & http_access

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem webpagge filter - acl & http_access

ndoigny
Hi All,

I did a Squid basic configuration on the port 3128.

The server proxy works correcly and I can browser from a client machine when
I configure the proxy configuration.
But when I try to do some web filtering on some sites, I always manage to
access it

I created a txt file 'blocked_sites' in the path 'C:\squid\etc\squid'.
I created the following ACL :
acl blocked_sites dstdomain '/etc/squid/blocked_sites.txt'
http_access deny blocked_sites

In the blocked_sites file txt, I indicate :

.facebook.com
.msn.com
.orange.be

I restarted the Squid service but the filter isn't working.

Can you help me ?

Thanks in advance.

Nicolas



--
Sent from: http://squid-web-proxy-cache.1019090.n4.nabble.com/Squid-Users-f1019091.html
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem webpagge filter - acl & http_access

Vacheslav Zouhairy
I too wanted to block, but it was youtube, and eventually the best way
to do it was squid + ufdbguard

On Tue, 2019-10-15 at 13:03 -0500, ndoigny wrote:

> Hi All,
>
> I did a Squid basic configuration on the port 3128.
>
> The server proxy works correcly and I can browser from a client
> machine when
> I configure the proxy configuration.
> But when I try to do some web filtering on some sites, I always
> manage to
> access it
>
> I created a txt file 'blocked_sites' in the path
> 'C:\squid\etc\squid'.
> I created the following ACL :
> acl blocked_sites dstdomain '/etc/squid/blocked_sites.txt'
> http_access deny blocked_sites
>
> In the blocked_sites file txt, I indicate :
>
> .facebook.com
> .msn.com
> .orange.be
>
> I restarted the Squid service but the filter isn't working.
>
> Can you help me ?
>
> Thanks in advance.
>
> Nicolas
>
>
>
> --
> Sent from:
> http://squid-web-proxy-cache.1019090.n4.nabble.com/Squid-Users-f1019091.html
> _______________________________________________
> squid-users mailing list
> [hidden email]
> http://lists.squid-cache.org/listinfo/squid-users


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem webpagge filter - acl & http_access

washuu
Most likely your browser redirects you to HTTPS, instead of HTTP, so
what you need is peek and splice.

On Wed, 16 Oct 2019 at 06:52, Vacheslav <[hidden email]> wrote:

>
> I too wanted to block, but it was youtube, and eventually the best way
> to do it was squid + ufdbguard
>
> On Tue, 2019-10-15 at 13:03 -0500, ndoigny wrote:
> > Hi All,
> >
> > I did a Squid basic configuration on the port 3128.
> >
> > The server proxy works correcly and I can browser from a client
> > machine when
> > I configure the proxy configuration.
> > But when I try to do some web filtering on some sites, I always
> > manage to
> > access it
> >
> > I created a txt file 'blocked_sites' in the path
> > 'C:\squid\etc\squid'.
> > I created the following ACL :
> > acl blocked_sites dstdomain '/etc/squid/blocked_sites.txt'
> > http_access deny blocked_sites
> >
> > In the blocked_sites file txt, I indicate :
> >
> > .facebook.com
> > .msn.com
> > .orange.be
> >
> > I restarted the Squid service but the filter isn't working.
> >
> > Can you help me ?
> >
> > Thanks in advance.
> >
> > Nicolas
> >
> >
> >
> > --
> > Sent from:
> > http://squid-web-proxy-cache.1019090.n4.nabble.com/Squid-Users-f1019091.html
> > _______________________________________________
> > squid-users mailing list
> > [hidden email]
> > http://lists.squid-cache.org/listinfo/squid-users
>
>
> _______________________________________________
> squid-users mailing list
> [hidden email]
> http://lists.squid-cache.org/listinfo/squid-users



--
Zanim wydrukujesz, pomyśl o środowisku.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem webpagge filter - acl & http_access

ndoigny
In reply to this post by ndoigny
Hi,

I tested with an acl .eurosport.com* and garagegardi.be* who aren't https
and it's working.

I see that for https pages, I need a root certificate that will be exported
to all machines.

Thank you for you help.

Nicolas



--
Sent from: http://squid-web-proxy-cache.1019090.n4.nabble.com/Squid-Users-f1019091.html
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users