Squid 3.5.28 can't be built on FreeBSD 12.0-RELEASE

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Squid 3.5.28 can't be built on FreeBSD 12.0-RELEASE

Marko Cupać
Hi,

it appears that Squid 3.5.28 (current FreeBSD port for www/squid3)
can't be built on latest FreeBSD release. The problem appears to be
related to openssl version in FreeBSD base, which is "OpenSSL
1.1.1a-freebsd  20 Nov 2018" according to `openssl version`.

Are there plans to patch Squid 3.5.X so it works on FreeBSD 12-RELEASE?

Here's excerpt from poudriere log:

---log-excerpt-start---
Making all in anyp
depbase=`echo PortCfg.lo | sed
's|[^/]*$|.deps/&|;s|\.lo$||'`; /bin/sh ../../libtool  --tag=CXX
--mode=compile c++ -DHAVE_CONFIG_H    -I../.. -I../../include
-I../../lib -I../../src  -I../../include  -I/usr/include
-I/usr/include  -I../../libltdl -I/usr/include -I/usr/local/include
-Werror -Qunused-arguments  -D_REENTRANT -I/usr/include -I/usr/include
-O2 -pipe -I/usr/local/include -fstack-protector -DLDAP_DEPRECATED
-fno-strict-aliasing  -Wno-unknown-warning-option
-Wno-undefined-bool-conversion -Wno-tautological-undefined-compare
-Wno-dynamic-class-memaccess  -I/usr/local/include -MT PortCfg.lo -MD
-MP -MF $depbase.Tpo -c -o PortCfg.lo PortCfg.cc && mv -f $depbase.Tpo
$depbase.Plo libtool: compile:  c++ -DHAVE_CONFIG_H -I../..
-I../../include -I../../lib -I../../src -I../../include -I/usr/include
-I/usr/include -I../../libltdl -I/usr/include -I/usr/local/include
-Werror -Qunused-arguments -D_REENTRANT -I/usr/include -I/usr/include
-O2 -pipe -I/usr/local/include -fstack-protector -DLDAP_DEPRECATED
-fno-strict-aliasing -Wno-unknown-warning-option
-Wno-undefined-bool-conversion -Wno-tautological-undefined-compare
-Wno-dynamic-class-memaccess -I/usr/local/include -MT PortCfg.lo -MD
-MP -MF .deps/PortCfg.Tpo -c PortCfg.cc  -fPIC -DPIC -o .libs/PortCfg.o
In file included from PortCfg.cc:10: In file included
from ../../src/anyp/PortCfg.h:18: ../../src/ssl/gadgets.h:83:45: error:
use of undeclared identifier 'CRYPTO_LOCK_X509' typedef
LockingPointer<X509, X509_free_cpp, CRYPTO_LOCK_X509> X509_Pointer;
^ ../../src/ssl/gadgets.h:89:53: error: use of undeclared identifier
'CRYPTO_LOCK_EVP_PKEY' typedef LockingPointer<EVP_PKEY,
EVP_PKEY_free_cpp, CRYPTO_LOCK_EVP_PKEY> EVP_PKEY_Pointer;
^ ../../src/ssl/gadgets.h:116:43: error: use of undeclared identifier
'CRYPTO_LOCK_SSL' typedef LockingPointer<SSL, SSL_free_cpp,
CRYPTO_LOCK_SSL> SSL_Pointer;
---log-excerpt-end---

Thank you in advance,
--
Before enlightenment - chop wood, draw water.
After  enlightenment - chop wood, draw water.

Marko Cupać
https://www.mimar.rs/
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Squid 3.5.28 can't be built on FreeBSD 12.0-RELEASE

Amos Jeffries
Administrator
On 24/12/18 11:41 pm, Marko Cupać wrote:
> Hi,
>
> it appears that Squid 3.5.28 (current FreeBSD port for www/squid3)
> can't be built on latest FreeBSD release. The problem appears to be
> related to openssl version in FreeBSD base, which is "OpenSSL
> 1.1.1a-freebsd  20 Nov 2018" according to `openssl version`.
>
> Are there plans to patch Squid 3.5.X so it works on FreeBSD 12-RELEASE?
>

No. Squid-3.5 is no longer supported for anything but security
vulnerabilities.

The current production series (Squid-4) already contains all the code
re-writes for use with OpenSSL-1.1.

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users