Squid 4.5 crashes on FreeBSD

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Squid 4.5 crashes on FreeBSD

Marko Cupać
Hi,

I am trying to move to Squid 4.x from 3.x on FreeBSD 12.0-RELEASE, but
so far it is quite unstable for me.

Right now I am using Squid 4.5, and it crashes, giving the following in
cache.log:
assertion failed: stmem.cc:98: "lowestOffset () <= target_offset"

messages log shows squid restarts:
Jan 16 11:07:52 squid2 squid[64423]: Squid Parent: squid-1 process
86491 exited due to signal 6 with status 0
Jan 16 11:07:52 squid2squid[64423]: Squid Parent: (squid-1) process 86729 started
Jan 16 11:12:26 squid2 squid[64423]: Squid Parent: squid-1 process
86729 exited due to signal 6 with status 0
Jan 16 11:12:26 squid2 squid[64423]: Squid Parent: (squid-1) process
86955 started

Could this be a software bug, or can I avoid this with configuration
change?

Thank you in advance,
--
Before enlightenment - chop wood, draw water.
After  enlightenment - chop wood, draw water.

Marko Cupać
https://www.mimar.rs/
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: Squid 4.5 crashes on FreeBSD

Alex Rousskov
On 1/17/19 3:41 AM, Marko Cupać wrote:

> I am using Squid 4.5, and it crashes, giving the following in cache.log:
> assertion failed: stmem.cc:98: "lowestOffset () <= target_offset"

Probably bug #4823:
https://bugs.squid-cache.org/show_bug.cgi?id=4823

Alex.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users