When connection closed when trying connect some urls

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

When connection closed when trying connect some urls

Ben Goz
B.H
Hi,
I saw that this question was asked several times, but I didn't get an answer that solves the problem.

This is the squidclient prompet I get:
x@x:~$ squidclient -v https://discountbank.co.il
Request:
GET https://discountbank.co.il HTTP/1.0
Host: discountbank.co.il
User-Agent: squidclient/3.5.27
Accept: */*
Connection: close

Any help will be appreciated.
Thanks,
Ben

_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: When connection closed when trying connect some urls

Alex Rousskov
On 10/26/20 10:40 AM, Ben Goz wrote:
> I saw that this question was asked several times, but I didn't get an
> answer that solves the problem.

> This is the squidclient prompet I get:
> x@x:~$ squidclient -v https://discountbank.co.il
> Request:
> GET https://discountbank.co.il HTTP/1.0
> Host: discountbank.co.il <http://discountbank.co.il>
> User-Agent: squidclient/3.5.27
> Accept: */*
> Connection: close

I am not sure what the actual question here is, but, AFAICT, squidclient
never submits more than one HTTP request and, hence, squidclient always
closes the connection after the first transaction.

You can control the value of the HTTP Connection header sent by
squidclient using the -k command line option. Again, regardless of that
option, squidclient will naturally close the connection after receiving
the response. My guess is that the command line option was added for
(Squid) testing purposes; it has no practical use beyond that very
limited scope.


HTH,

Alex.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: When connection closed when trying connect some urls

Ben Goz
B.H
Hi Alex,
Thanks for your quick answer, the example with squidclient is not a good example.
The real issue is that I get TCP_MISSED_ABORTED/000 and the browsers gets timed out when connecting to

How can i further investigate this issue and reconfig squid so it'll work.

Thanks,
Ben



_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: When connection closed when trying connect some urls

Matus UHLAR - fantomas
On 26.10.20 17:43, Ben Goz wrote:
>Thanks for your quick answer, the example with squidclient is not a good
>example.
>The real issue is that I get TCP_MISSED_ABORTED/000 and the browsers gets
>timed out when connecting to
>https://dicountbank.co.il.
>
>How can i further investigate this issue and reconfig squid so it'll work.

I guess squidclient can not handle https connections.

https connections are to be tunneled by squid to destination server, where
client itself will decrypt the connection. squidclient is not this kind of
client.

try wget or curl.

--
Matus UHLAR - fantomas, [hidden email] ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
Atheism is a non-prophet organization.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: When connection closed when trying connect some urls

Ben Goz
B.H
As I said, squidclient is not the issue here.
I'm getting TCP_MISSED_ABOTED when connecting via browser using squid as a non transparent proxy.
Squid configured with ssl bump and I'm trying to splice this url but it's still not working.
How can I further investigate and what squid configuration should I need to consider in order to fix it?


‫בתאריך יום ב׳, 26 באוק׳ 2020 ב-18:08 מאת ‪Matus UHLAR - fantomas‬‏ <‪[hidden email]‬‏>:‬
On 26.10.20 17:43, Ben Goz wrote:
>Thanks for your quick answer, the example with squidclient is not a good
>example.
>The real issue is that I get TCP_MISSED_ABORTED/000 and the browsers gets
>timed out when connecting to
>https://dicountbank.co.il.
>
>How can i further investigate this issue and reconfig squid so it'll work.

I guess squidclient can not handle https connections.

https connections are to be tunneled by squid to destination server, where
client itself will decrypt the connection. squidclient is not this kind of
client.

try wget or curl.

--
Matus UHLAR - fantomas, [hidden email] ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
Atheism is a non-prophet organization.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users

_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: When connection closed when trying connect some urls

Alex Rousskov
In reply to this post by Ben Goz
On 10/26/20 11:43 AM, Ben Goz wrote:

> The real issue is that I get TCP_MISSED_ABORTED/000 and the browsers
> gets timed out when connecting to https://dicountbank.co.il.

> How can i further investigate this issue

On the surface, it sounds like your Squid does not receive a response
from the DNS or HTTP server (fast enough), resulting in client timeouts
and TCP_MISS_ABORTED/000 access.log records.

There are several ways to find out the reason behind the timeouts. For
example, one can exclude or confirm DNS timeouts by monitoring DNS
transactions using wireshark. The easiest method for _me_ is to analyze
Squid debugging logs, but I do not recommend doing that without good
Squid code knowledge.

Can you isolate the problem to a single transaction that you can
reproduce at will, with no other traffic going through your Squid? If
yes, then you can try posting a link to a compressed cache.log with
debug_options set to ALL,9 while reproducing the problem. Hopefully,
somebody with enough Squid code knowledge will triage the problem for
you. See Squid FAQ for more details:
https://wiki.squid-cache.org/SquidFaq/BugReporting#Debugging_a_single_transaction

Alex.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users