c-icap documentation getting stuck

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

c-icap documentation getting stuck

robert k Wild
hi all,

following this guide and so far so good


when i was configuring the clamav i followed this link


im getting stuck on this bit

ln -s /var/lib/clamav /usr/local/clamav/share/clamav

theres no "/usr/local/clamav/share/clamav"

thanks all,
rob
--
Regards,

Robert K Wild.

_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: c-icap documentation getting stuck

Amos Jeffries
Administrator
On 22/12/19 4:25 am, robert k Wild wrote:

> hi all,
>
> following this guide and so far so good
>
> https://wiki.squid-cache.org/ConfigExamples/ContentAdaptation/C-ICAP
>
> when i was configuring the clamav i followed this link
>
> https://hostpresto.com/community/tutorials/how-to-install-clamav-on-centos-7/
>
> im getting stuck on this bit
>
> ln -s /var/lib/clamav /usr/local/clamav/share/clamav
>
> theres no "/usr/local/clamav/share/clamav"
>

That command is for creating it.

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: c-icap documentation getting stuck

robert k Wild
thanks Amos

i did this

mkdir -p /usr/local/clamav/share/clamav
ln -s /var/lib/clamav /usr/local/clamav/share/clamav

but how do i start up the c-icap service as that how to doesnt state how to make a c-icap service?

thanks,
rob

On Sat, 21 Dec 2019 at 16:36, Amos Jeffries <[hidden email]> wrote:
On 22/12/19 4:25 am, robert k Wild wrote:
> hi all,
>
> following this guide and so far so good
>
> https://wiki.squid-cache.org/ConfigExamples/ContentAdaptation/C-ICAP
>
> when i was configuring the clamav i followed this link
>
> https://hostpresto.com/community/tutorials/how-to-install-clamav-on-centos-7/
>
> im getting stuck on this bit
>
> ln -s /var/lib/clamav /usr/local/clamav/share/clamav
>
> theres no "/usr/local/clamav/share/clamav"
>

That command is for creating it.

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users


--
Regards,

Robert K Wild.

_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: c-icap documentation getting stuck

robert k Wild
worked it out

but c-icap doesnt run, i get this error (only showing the error not the whole info) -

/usr/local/bin/c-icap -N -D -d 10

Cannot open the pid file: /var/run/c-icap/c-icap.pid

but in my "c-icap.conf" the pid file is uncommented so i really dont know why its not starting up

thanks,
rob

On Sat, 21 Dec 2019 at 17:48, robert k Wild <[hidden email]> wrote:
thanks Amos

i did this

mkdir -p /usr/local/clamav/share/clamav
ln -s /var/lib/clamav /usr/local/clamav/share/clamav

but how do i start up the c-icap service as that how to doesnt state how to make a c-icap service?

thanks,
rob

On Sat, 21 Dec 2019 at 16:36, Amos Jeffries <[hidden email]> wrote:
On 22/12/19 4:25 am, robert k Wild wrote:
> hi all,
>
> following this guide and so far so good
>
> https://wiki.squid-cache.org/ConfigExamples/ContentAdaptation/C-ICAP
>
> when i was configuring the clamav i followed this link
>
> https://hostpresto.com/community/tutorials/how-to-install-clamav-on-centos-7/
>
> im getting stuck on this bit
>
> ln -s /var/lib/clamav /usr/local/clamav/share/clamav
>
> theres no "/usr/local/clamav/share/clamav"
>

That command is for creating it.

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users


--
Regards,

Robert K Wild.


--
Regards,

Robert K Wild.

_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: c-icap documentation getting stuck

robert k Wild
finally getting somewhere, i did -

mkdir /var/run/c-icap
chown squid:squid /var/run/c-icap/
chmod 700 /var/run/c-icap/

and now when i run -

/usr/local/bin/c-icap -N -D -d 10

i dont get any errors but when i run the below i get warnings

 /usr/local/bin/c-icap
WARNING Bad configuration keyword: enable_libarchive 0
WARNING Bad configuration keyword: banmaxsize 2M

thanks,
rob




On Sat, 21 Dec 2019 at 18:28, robert k Wild <[hidden email]> wrote:
worked it out

but c-icap doesnt run, i get this error (only showing the error not the whole info) -

/usr/local/bin/c-icap -N -D -d 10

Cannot open the pid file: /var/run/c-icap/c-icap.pid

but in my "c-icap.conf" the pid file is uncommented so i really dont know why its not starting up

thanks,
rob

On Sat, 21 Dec 2019 at 17:48, robert k Wild <[hidden email]> wrote:
thanks Amos

i did this

mkdir -p /usr/local/clamav/share/clamav
ln -s /var/lib/clamav /usr/local/clamav/share/clamav

but how do i start up the c-icap service as that how to doesnt state how to make a c-icap service?

thanks,
rob

On Sat, 21 Dec 2019 at 16:36, Amos Jeffries <[hidden email]> wrote:
On 22/12/19 4:25 am, robert k Wild wrote:
> hi all,
>
> following this guide and so far so good
>
> https://wiki.squid-cache.org/ConfigExamples/ContentAdaptation/C-ICAP
>
> when i was configuring the clamav i followed this link
>
> https://hostpresto.com/community/tutorials/how-to-install-clamav-on-centos-7/
>
> im getting stuck on this bit
>
> ln -s /var/lib/clamav /usr/local/clamav/share/clamav
>
> theres no "/usr/local/clamav/share/clamav"
>

That command is for creating it.

Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users


--
Regards,

Robert K Wild.


--
Regards,

Robert K Wild.


--
Regards,

Robert K Wild.

_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: c-icap documentation getting stuck

Alex Crow
In reply to this post by robert k Wild
robert,

I'd go the ecap way if I was you - no daemons to set up, just a library.
c-icap has always been an issue as distros packages have never really
acknowledged it exists in terms of permissions.

The ecap way avoids all of that mess entirely.

http://www.e-cap.org/docs/

http://www.e-cap.org/downloads/

https://wiki.squid-cache.org/Features/eCAP


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: c-icap documentation getting stuck

Alex Crow
In reply to this post by robert k Wild

>
> i dont get any errors but when i run the below i get warnings
>
>  /usr/local/bin/c-icap
> WARNING Bad configuration keyword: enable_libarchive 0
> WARNING Bad configuration keyword: banmaxsize 2M
>
> thanks,
> rob
>
You should be asking these questions on whatever resources c-icap
provide for that purpose, eg their GitHub issues page. c-icap is not
related in any way to the Squid project.


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

squid log responce time %6tr or %tr ?

Ahmad Alzaeem
Hello Team ,

based on wiki :
tr is responce time , but im confused on why default response time configured as %6tr not %tr 

#################
logformat squid %ts.%03tu %6tr %>a %Ss/%03>Hs %<st %rm %ru %[un %Sh/%<a %mt

##############


is there any difference between %tr and %6tr ?



Thanks 





_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: c-icap documentation getting stuck

Vieri Di Paola
In reply to this post by robert k Wild
On Sat, Dec 21, 2019 at 7:42 PM robert k Wild <[hidden email]> wrote:
>
> WARNING Bad configuration keyword: enable_libarchive 0
> WARNING Bad configuration keyword: banmaxsize 2M

You're probably running an outdated squidclamav.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: squid log responce time %6tr or %tr ?

Alex Rousskov
In reply to this post by Ahmad Alzaeem
On 12/22/19 5:53 AM, Ahmad Alzaeem wrote:

> im confused on why default response time configured as %6tr not %tr

Many Squid developers look at raw access logs. I suspect early Squid
developers wanted to first (or "left") access.log fields at a semi-fixed
position. Making most response time entries 6 characters long helps with
that goal.


> is there any difference between %tr and %6tr ?

Yes, %6tr is padded with spaces on the left (if its value is smaller
than 1000000) to make the entire value at least 6 characters long. This
is semi-documented in logformat directive description (look for
"width"): http://www.squid-cache.org/Doc/config/logformat/

Alex.
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users