domains with accented international characters fail with Invalid URL

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

domains with accented international characters fail with Invalid URL

Patrick Chemla

Hi,


In the past I asked few questions here and got very efficient help, so I try again.


I have a french domain using accented letters in the domain name itself  like "aaaébbbéooooooo.com" knowned as xn--xxx-xxx.fr in DNS and Apache configuration.


I am trying to setup squid 3.5.20 (last version updated  as an available package on Centos 7.7) as a proxy cache  to deliver images for all domains on this server, but it fails for that particular domain with message Invalid URL.


Here are the access_logs:


- 88.88.88.xx - - - [12/May/2020:08:05:43 +0200] " @%F1%F4%EA%F8?%80%E6Q%EAWH%D5%04zEa)%B1%A7%C1%9B%AA - HTTP/1.1" 400 3941 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:05:52 +0200] "GET / - HTTP/1.1" 400 3755 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:05:52 +0200] "GET http://hostname:3128/squid-internal-static/icons/SN.png /squid-internal-static/icons/SN.png HTTP/1.1" 200 12939 0 "http://www.xn--xxx-xxx.fr:3128/" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" TCP_MEM_HIT:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:05:52 +0200] "GET /favicon.ico - HTTP/1.1" 400 3777 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:07:23 +0200] "GET / - HTTP/1.1" 400 3755 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:07:23 +0200] "GET http://hostname:3128/squid-internal-static/icons/SN.png /squid-internal-static/icons/SN.png HTTP/1.1" 200 12939 0 "http://xn--xxx-xxx.fr:3128/" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" TCP_MEM_HIT:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:07:23 +0200] "GET /favicon.ico - HTTP/1.1" 400 3777 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:16:16 +0200] "GET / - HTTP/1.1" 400 3755 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:16:16 +0200] "GET http://hostname:3128/squid-internal-static/icons/SN.png /squid-internal-static/icons/SN.png HTTP/1.1" 200 4098 0 "http://www.xn--xxx-xxx.fr:3128/" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" TCP_MEM_HIT_ABORTED:HIER_NONE


I tried to search google  but can't find any details on a special setting in squid.conf to accept accented internationals letters.


Maybe someone here could help?


Many thanks in advance.


Patrick


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: domains with accented international characters fail with Invalid URL

Patrick Chemla

Sorry for this, it seems it is not linked to accented characters. Other not accented domains don't work too.


I am checking my configuration.


Patrick

Le 12/05/2020 à 14:40, Patrick Chemla a écrit :

Hi,


In the past I asked few questions here and got very efficient help, so I try again.


I have a french domain using accented letters in the domain name itself  like "aaaébbbéooooooo.com" knowned as xn--xxx-xxx.fr in DNS and Apache configuration.


I am trying to setup squid 3.5.20 (last version updated  as an available package on Centos 7.7) as a proxy cache  to deliver images for all domains on this server, but it fails for that particular domain with message Invalid URL.


Here are the access_logs:


- 88.88.88.xx - - - [12/May/2020:08:05:43 +0200] " @%F1%F4%EA%F8?%80%E6Q%EAWH%D5%04zEa)%B1%A7%C1%9B%AA - HTTP/1.1" 400 3941 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:05:52 +0200] "GET / - HTTP/1.1" 400 3755 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:05:52 +0200] "GET http://hostname:3128/squid-internal-static/icons/SN.png /squid-internal-static/icons/SN.png HTTP/1.1" 200 12939 0 "http://www.xn--xxx-xxx.fr:3128/" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" TCP_MEM_HIT:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:05:52 +0200] "GET /favicon.ico - HTTP/1.1" 400 3777 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:07:23 +0200] "GET / - HTTP/1.1" 400 3755 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:07:23 +0200] "GET http://hostname:3128/squid-internal-static/icons/SN.png /squid-internal-static/icons/SN.png HTTP/1.1" 200 12939 0 "http://xn--xxx-xxx.fr:3128/" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" TCP_MEM_HIT:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:07:23 +0200] "GET /favicon.ico - HTTP/1.1" 400 3777 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:16:16 +0200] "GET / - HTTP/1.1" 400 3755 0 "-" "-" TAG_NONE:HIER_NONE
- 88.88.88.xx - - - [12/May/2020:08:16:16 +0200] "GET http://hostname:3128/squid-internal-static/icons/SN.png /squid-internal-static/icons/SN.png HTTP/1.1" 200 4098 0 "http://www.xn--xxx-xxx.fr:3128/" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0" TCP_MEM_HIT_ABORTED:HIER_NONE


I tried to search google  but can't find any details on a special setting in squid.conf to accept accented internationals letters.


Maybe someone here could help?


Many thanks in advance.


Patrick


_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users

_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users
Reply | Threaded
Open this post in threaded view
|

Re: domains with accented international characters fail with Invalid URL

Amos Jeffries
Administrator
On 13/05/20 12:20 am, Patrick Chemla wrote:
> Sorry for this, it seems it is not linked to accented characters. Other
> not accented domains don't work too.
>


This is a huge clue in your log:

>>
>> *- 88.88.88.xx - - - [12/May/2020:08:05:43 +0200] "
>> @%F1%F4%EA%F8?%80%E6Q%EAWH%D5%04zEa)%B1%A7%C1%9B%AA - HTTP/1.1" 400
>> 3941 0 "-" "-" TAG_NONE:HIER_NONE


Whatever client is generating this traffic is not talking HTTP to the proxy.


Amos
_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users