some pages doesn't open in transparent mode

Previous Topic Next Topic
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
Report Content as Inappropriate

some pages doesn't open in transparent mode

mikie mike

I have this quite weird problem with Squid working with Cisco 6509
Core Switch as WCCP transparent proxy.
Some pages doesn't open on clients (or it takes ages to open).

There is a Polish web portal which many people visit - www.onet.pl -
this is the one of very few which suffers.
When I open the page in FF it says: "Waiting for csr.onet.pl…"
I can not see any record in access.log regarding csr.onet.pl then (why?).
If I type "csr.onet.pl" into FF there is no record in access.log either (why??).

When I do "w3m www.onet.pl" on the client it opens OK.
Also "w3m csr.onet.pl" generates record in access.log:
1267439340.585     71 TCP_MISS/404 629 GET
http://csr.onet.pl/ - DIRECT/ text/html

The most weird thing is that some clients open the page, some not:
Safari on Mac OS X works OK
FF on Mac OS X works OK
Opera doesn't work on Linux nor Mac OS X

Everything works great on every browser when I use explicit proxy
(manually config proxy in browser).

What I have is:
Debian 5 Lenny (current updates)
Squid Cache: Version 2.7.STABLE3
wccp2_forwarding_method 1
wccp2_return_method 1
wccp2_service standard 0
GRE tunnel at Debian
-A PREROUTING -i gre0 -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 3128
IOS (tm) c6sup2_rp Software (c6sup2_rp-PSV-M), Version 12.1(27b)E3,
#show ip wccp web-cache detail
WCCP Cache-Engine information:
Web Cache ID:
Protocol Version:      2.0
State:                 Usable
Redirection:           GRE
Packet Return:         GRE
Assignment:            HASH
Initial Hash Info:     00000000000000000000000000000000
Hash Allotment:        256 (100.00%)
Packets Redirected:    4164751
Connect Time:          09:43:21

Best Regards,