[squid-announce] [ADVISORY] SQUID-2020:6 Denial of Service issue in TLS Handshake

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[squid-announce] [ADVISORY] SQUID-2020:6 Denial of Service issue in TLS Handshake

Amos Jeffries
Administrator
__________________________________________________________________

    Squid Proxy Cache Security Update Advisory SQUID-2020:6
__________________________________________________________________

 Advisory ID:       | SQUID-2020:6
 Date:              | June 19, 2020
 Summary:           | Denial of Service issue in TLS Handshake
 Affected versions: | Squid 3.1 -> 3.5.28
                    | Squid 4.x -> 4.11
                    | Squid 5.x -> 5.0.2
 Fixed in version:  | Squid 4.12 and 5.0.3

__________________________________________________________________

  <http://www.squid-cache.org/Advisories/SQUID-2020_6.txt>
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14058>

<https://github.com/squid-cache/squid/security/advisories/GHSA-qvf6-485q-vm57>
__________________________________________________________________

Problem Description:

 Due to use of a potentially dangerous function Squid and the
 default certificate validation helper are vulnerable to a Denial
 of Service attack when processing TLS certificates.

__________________________________________________________________

Severity:

 This problem allows a trusted client to perform Denial of Service
 when opening TLS connections with a server for HTTPS.

 This problem allows a trusted client to perform Denial of Service
 when opening TLS connections to a server for SSL-Bump intercepted
 transactions.

 This attack is limited to Squid built with OpenSSL features and
 opening peer or server connections for HTTPS traffic and SSL-Bump
 server handshakes.

 CVSS Score of 8.3
 <https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H/E:F/RL:O/RC:C/CR:X/IR:X/AR:H/MAV:N/MAC:H/MPR:N/MUI:X/MS:C/MC:N/MI:N/MA:H&version=3.1>

__________________________________________________________________

Updated Packages:

This bug is fixed by Squid versions 4.12 and 5.0.3.

 In addition, patches addressing this problem for the stable
 releases can be found in our patch archives:

Squid 4:
 <http://www.squid-cache.org/Versions/v4/changesets/squid-4-93f5fda134a2a010b84ffedbe833d670e63ba4be.patch>

Squid 5:
 <http://www.squid-cache.org/Versions/v5/changesets/squid-5-c6d1a4f6a2cbebceebc8a3fcd8f539ceb7b7f723.patch>

 If you are using a prepackaged version of Squid then please refer
 to the package vendor for availability information on updated
 packages.

__________________________________________________________________

Determining if your version is vulnerable:

 All Squid-2.x up to and including 2.7.STABLE9 are not vulnerable.

 All Squid-3.x up to and including 3.4.14 built without
 --enable-openssl are not vulnerable.

 All Squid-3.x up to and including 3.4.14 built with
 --disable-openssl are not vulnerable.

 All Squid-3.x up to and including 3.4.14 built with
 --enable-openssl are vulnerable.

 All Squid-3.5 up to and including 3.5.28 built without
 --with-openssl are not vulnerable.

 All Squid-3.5 up to and including 3.5.28 built with
 --without-openssl are not vulnerable.

 All Squid-3.5 up to and including 3.5.28 built with
 --with-openssl are vulnerable.

 All Squid-4.x up to and including 4.11 built without
 --with-openssl are not vulnerable.

 All Squid-4.x up to and including 4.11 built with
 --without-openssl are not vulnerable.

 All Squid-4.x up to and including 4.11 built with --with-openssl
 are vulnerable.

 Squid-5.0.1 and 5.0.2 built without --with-openssl are not
 vulnerable.

 Squid-5.0.1 and 5.0.2 built with --without-openssl are not
 vulnerable.

 Squid-5.0.1 and 5.0.2 built with --with-openssl are vulnerable.

__________________________________________________________________

Workaround:

 * For interception proxies using SSL-Bump functionality there is
   no workaround.

 * For reverse-proxy the GnuTLS support available in Squid-4 may
   provide sufficient functionality. The vulnerable certificate
   validator helper feature is not supported yet by GnuTLS builds.

 * Other installations just needing to relay HTTPS do not need
   OpenSSL support and should be able to run a build that does not
   have --with-openssl.

__________________________________________________________________

Contact details for the Squid project:

 For installation / upgrade support on binary packaged versions
 of Squid: Your first point of contact should be your binary
 package vendor.

 If you install and build Squid from the original Squid sources
 then the <[hidden email]> mailing list is your
 primary support point. For subscription details see
 <http://www.squid-cache.org/Support/mailing-lists.html>.

 For reporting of non-security bugs in the latest STABLE release
 the squid bugzilla database should be used
 <http://bugs.squid-cache.org/>.

 For reporting of security sensitive bugs send an email to the
 <[hidden email]> mailing list. It's a closed
 list (though anyone can post) and security related bug reports
 are treated in confidence until the impact has been established.

__________________________________________________________________

Credits:

 This vulnerability was discovered by Dimitra Azariadi and Mario
 Galli of Open Systems AG.

 Fixed by Christos Tsantilas of The Measurement Factory.

__________________________________________________________________

Revision history:

 2020-03-04 09:31:23 UTC Initial Report
 2020-05-15 04:54:54 UTC Patches Released
__________________________________________________________________
END
_______________________________________________
squid-announce mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-announce