squidclamav cant connect to clamd service

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

squidclamav cant connect to clamd service

robert k Wild

hi all,

ive been struggling with this for a few weeks and hopefully one of you guys can help me out as im struggling finding solutions

ive installed on my centos 7 vm machine

c-icap

c-icap modules

http://c-icap.sourceforge.net/download.html

squid 4.9

http://www.squid-cache.org/Versions/v4/

clamav

https://hostpresto.com/community/tutorials/how-to-install-clamav-on-centos-7/

squidclamav

https://sourceforge.net/projects/squidclamav/files/latest/download

and i followed this guide compiling them from source with the configure options make and make install on all of them

https://wiki.squid-cache.org/ConfigExamples/ContentAdaptation/C-ICAP

squid works as a proxy just fine, just struggling with the c-icap with squidclamav part

this is the error i get -

Sun Dec 22 21:40:44 2019, 1586/40797952, squidclamav.c(2081) dconnect: Sun Dec 22 21:40:44 2019, 1586/40797952, ERROR Can't connect to clamd on local socket /run/clamd.scan/clamd.sock.
Sun Dec 22 21:40:44 2019, 1586/40797952, squidclamav.c(787) squidclamav_end_of_data_handler: Sun Dec 22 21:40:44 2019, 1586/40797952, ERROR Can't connect to Clamd daemon.
Mon Dec 23 10:10:11 2019, main proc, c-icap server already running!
Mon Dec 23 10:37:44 2019, main proc, c-icap server already running!
[root@squid ~]# ls /run/clamd.scan/
[root@squid ~]#

but i have changed all my services to a /services directory and there all running -

[root@squid ~]# ls /services/c-icap/
c-icap.ctl c-icap.pid
[root@squid ~]# ls /services/clamd.scan/
clamd.sock
[root@squid ~]#

so my question is why is squidclamav still looking in "/run/clamd.scan/clamd.sock"

i have even specified in my "/etc/squidclamav.conf" where the clamd service is

# clamd_port to the corresponding value.
clamd_local /services/clamd.scan/clamd.sock
#clamd_ip 127.0.0.1
#clamd_port 3310

but i have resolved it by this :)

so in my squid.conf i added the c-icap lines using this site as the link i gave, gave a c-icap protocol error, everytime i opened a web page

https://www.server-world.info/en/note?os=CentOS_7&p=squid&f=5 (the c-icap lines are at the end of the guide)

i also did this

vi /etc/tmpfiles.d/c-icap.conf
d /run/c-icap 0770 root root -

vi /etc/tmpfiles.d/clamd.scan.conf
d /run/clamd.scan 0770 root root -

i also made c-icap.conf and clamd.d/scan.conf, i made the user root just to make my life a lot easier not to run into any troubleshooting problems

and finally this command to re-initialise squidclamav with the c-icap configs

echo -n "squidclamav:cfgreload" > /run/c-icap/c-icap.ctl

then when i went on the http://www.eicar.org/download/eicar_com.zip

i got a virus found



_______________________________________________
squid-users mailing list
[hidden email]
http://lists.squid-cache.org/listinfo/squid-users