suqid proxy and localhost problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

suqid proxy and localhost problem

zigniew szalbot
Hello,

I am quite new to squid. I did a very minimal configuration started the
software, configured browsers and all seems ok. With one exception. The box
on which I run squid does not open http pages which it serves. Can you
advise me what I need to set up to allow this box to talk to me on port 80?
For now, I do not use any SSL, squid is configured with the default port.

Here is the information from cache.log

2007/07/05 13:32:07| Using kqueue for the IO loop
2007/07/05 13:32:07| DNS Socket created at 0.0.0.0, port 52483, FD 5
2007/07/05 13:32:07| Adding nameserver 194.204.152.34 from /etc/resolv.conf
2007/07/05 13:32:07| User-Agent logging is disabled.
2007/07/05 13:32:07| Referer logging is disabled.
2007/07/05 13:32:07| Unlinkd pipe opened on FD 10
2007/07/05 13:32:07| Swap maxSize 512000 KB, estimated 39384 objects
2007/07/05 13:32:07| Target number of buckets: 1969
2007/07/05 13:32:07| Using 8192 Store buckets
2007/07/05 13:32:07| Max Mem  size: 8192 KB
2007/07/05 13:32:07| Max Swap size: 512000 KB
2007/07/05 13:32:07| Rebuilding storage in /usr/local/squid/cache (CLEAN)
2007/07/05 13:32:07| Using Least Load store dir selection
2007/07/05 13:32:07| Set Current Directory to /usr/local/squid/cache
2007/07/05 13:32:07| Loaded Icons.
2007/07/05 13:32:07| Accepting proxy HTTP connections at 0.0.0.0, port
3128, FD 12.
2007/07/05 13:32:07| Accepting ICP messages at 0.0.0.0, port 3130, FD 13.
2007/07/05 13:32:07| WCCP Disabled.
2007/07/05 13:32:07| Pinger socket opened on FD 15
2007/07/05 13:32:08| NETDB state reloaded; 24 entries, 312 msec
2007/07/05 13:32:08| Ready to serve requests.
2007/07/05 13:32:08| Done reading /usr/local/squid/cache swaplog (618
entries)
2007/07/05 13:32:08| Finished rebuilding storage from disk.
2007/07/05 13:32:08|       618 Entries scanned
2007/07/05 13:32:08|         0 Invalid entries.
2007/07/05 13:32:08|         0 With invalid flags.
2007/07/05 13:32:08|       618 Objects loaded.
2007/07/05 13:32:08|         0 Objects expired.
2007/07/05 13:32:08|         0 Objects cancelled.
2007/07/05 13:32:08|         0 Duplicate URLs purged.
2007/07/05 13:32:08|         0 Swapfile clashes avoided.
2007/07/05 13:32:08|   Took 0.3 seconds (1887.1 objects/sec).
2007/07/05 13:32:08| Beginning Validation Procedure
2007/07/05 13:32:08|   Completed Validation Procedure
2007/07/05 13:32:08|   Validated 618 Entries
2007/07/05 13:32:08|   store_swap_size = 3512k
2007/07/05 13:32:08| storeLateRelease: released 0 objects

Thank you very much in advance for your help!

Reply | Threaded
Open this post in threaded view
|

Re: suqid proxy and localhost problem

Amos Jeffries
Administrator
Zbigniew Szalbot wrote:
> Hello,
>
> I am quite new to squid. I did a very minimal configuration started the
> software, configured browsers and all seems ok. With one exception. The box
> on which I run squid does not open http pages which it serves.

Depends on what you mean by 'it serves' and 'does not open'.
You probably want "http_access allow localhost" in squid.conf

> Can you
> advise me what I need to set up to allow this box to talk to me on port 80?
> For now, I do not use any SSL, squid is configured with the default port.

Yes. Squid would be talking to you on 3128 then. Port 80 is not the
default port.

Though why you would want to is something to consider very carefully.
Having it pretend to be a webserver is called reverse-proxy and has
different config needs, that vary from easy to tricky depending on things.

Amos
Reply | Threaded
Open this post in threaded view
|

Re: suqid proxy and localhost problem

Tek Bahadur Limbu
In reply to this post by zigniew szalbot
Zbigniew Szalbot wrote:

> Hello,
>
> I am quite new to squid. I did a very minimal configuration started the
> software, configured browsers and all seems ok. With one exception. The box
> on which I run squid does not open http pages which it serves. Can you
> advise me what I need to set up to allow this box to talk to me on port 80?
> For now, I do not use any SSL, squid is configured with the default port.
>
> Here is the information from cache.log
>
> 2007/07/05 13:32:07| Using kqueue for the IO loop
> 2007/07/05 13:32:07| DNS Socket created at 0.0.0.0, port 52483, FD 5
> 2007/07/05 13:32:07| Adding nameserver 194.204.152.34 from /etc/resolv.conf
> 2007/07/05 13:32:07| User-Agent logging is disabled.
> 2007/07/05 13:32:07| Referer logging is disabled.
> 2007/07/05 13:32:07| Unlinkd pipe opened on FD 10
> 2007/07/05 13:32:07| Swap maxSize 512000 KB, estimated 39384 objects
> 2007/07/05 13:32:07| Target number of buckets: 1969
> 2007/07/05 13:32:07| Using 8192 Store buckets
> 2007/07/05 13:32:07| Max Mem  size: 8192 KB
> 2007/07/05 13:32:07| Max Swap size: 512000 KB
> 2007/07/05 13:32:07| Rebuilding storage in /usr/local/squid/cache (CLEAN)
> 2007/07/05 13:32:07| Using Least Load store dir selection
> 2007/07/05 13:32:07| Set Current Directory to /usr/local/squid/cache
> 2007/07/05 13:32:07| Loaded Icons.
> 2007/07/05 13:32:07| Accepting proxy HTTP connections at 0.0.0.0, port
> 3128, FD 12.
> 2007/07/05 13:32:07| Accepting ICP messages at 0.0.0.0, port 3130, FD 13.
> 2007/07/05 13:32:07| WCCP Disabled.
> 2007/07/05 13:32:07| Pinger socket opened on FD 15
> 2007/07/05 13:32:08| NETDB state reloaded; 24 entries, 312 msec
> 2007/07/05 13:32:08| Ready to serve requests.
> 2007/07/05 13:32:08| Done reading /usr/local/squid/cache swaplog (618
> entries)
> 2007/07/05 13:32:08| Finished rebuilding storage from disk.
> 2007/07/05 13:32:08|       618 Entries scanned
> 2007/07/05 13:32:08|         0 Invalid entries.
> 2007/07/05 13:32:08|         0 With invalid flags.
> 2007/07/05 13:32:08|       618 Objects loaded.
> 2007/07/05 13:32:08|         0 Objects expired.
> 2007/07/05 13:32:08|         0 Objects cancelled.
> 2007/07/05 13:32:08|         0 Duplicate URLs purged.
> 2007/07/05 13:32:08|         0 Swapfile clashes avoided.
> 2007/07/05 13:32:08|   Took 0.3 seconds (1887.1 objects/sec).
> 2007/07/05 13:32:08| Beginning Validation Procedure
> 2007/07/05 13:32:08|   Completed Validation Procedure
> 2007/07/05 13:32:08|   Validated 618 Entries
> 2007/07/05 13:32:08|   store_swap_size = 3512k
> 2007/07/05 13:32:08| storeLateRelease: released 0 objects
>
> Thank you very much in advance for your help!
>
>
>
>

Hi Zbigniew,

Can you telnet to www.yahoo.com from your localhost (Squid Box). Since
you are using kqueue, I suppose you are running some firewall on your
BSD box.

When you try to browse websites on port 80 from your local Squid box,
what does access.log and cache.log say?

Can you post your squid.conf and your firewall script?

Thanking you...


--

With best regards and good wishes,

Yours sincerely,

Tek Bahadur Limbu

(TAG/TDG Group)
Jwl Systems Department

Worldlink Communications Pvt. Ltd.

Jawalakhel, Nepal

http://www.wlink.com.np
Reply | Threaded
Open this post in threaded view
|

Re: suqid proxy and localhost problem

Isnard Jaquet
In reply to this post by zigniew szalbot
Hi,

I don't think I understand what you mean. Are you trying to connect to
port 80 of your proxy? Is that it? Is apache installed and running (on
port 80)? If it is, put the ip address of it in the exceptions list on
your browser or disable the proxy from it when trying to connect to the
apache on your proxy server.

Did I get it right? If not, please explain a bit further.

Regards,

Isnard


Em Qui, 2007-07-05 às 13:40 +0200, Zbigniew Szalbot escreveu:

> Hello,
>
> I am quite new to squid. I did a very minimal configuration started the
> software, configured browsers and all seems ok. With one exception. The box
> on which I run squid does not open http pages which it serves. Can you
> advise me what I need to set up to allow this box to talk to me on port 80?
> For now, I do not use any SSL, squid is configured with the default port.
>
> Here is the information from cache.log
>
> 2007/07/05 13:32:07| Using kqueue for the IO loop
> 2007/07/05 13:32:07| DNS Socket created at 0.0.0.0, port 52483, FD 5
> 2007/07/05 13:32:07| Adding nameserver 194.204.152.34 from /etc/resolv.conf
> 2007/07/05 13:32:07| User-Agent logging is disabled.
> 2007/07/05 13:32:07| Referer logging is disabled.
> 2007/07/05 13:32:07| Unlinkd pipe opened on FD 10
> 2007/07/05 13:32:07| Swap maxSize 512000 KB, estimated 39384 objects
> 2007/07/05 13:32:07| Target number of buckets: 1969
> 2007/07/05 13:32:07| Using 8192 Store buckets
> 2007/07/05 13:32:07| Max Mem  size: 8192 KB
> 2007/07/05 13:32:07| Max Swap size: 512000 KB
> 2007/07/05 13:32:07| Rebuilding storage in /usr/local/squid/cache (CLEAN)
> 2007/07/05 13:32:07| Using Least Load store dir selection
> 2007/07/05 13:32:07| Set Current Directory to /usr/local/squid/cache
> 2007/07/05 13:32:07| Loaded Icons.
> 2007/07/05 13:32:07| Accepting proxy HTTP connections at 0.0.0.0, port
> 3128, FD 12.
> 2007/07/05 13:32:07| Accepting ICP messages at 0.0.0.0, port 3130, FD 13.
> 2007/07/05 13:32:07| WCCP Disabled.
> 2007/07/05 13:32:07| Pinger socket opened on FD 15
> 2007/07/05 13:32:08| NETDB state reloaded; 24 entries, 312 msec
> 2007/07/05 13:32:08| Ready to serve requests.
> 2007/07/05 13:32:08| Done reading /usr/local/squid/cache swaplog (618
> entries)
> 2007/07/05 13:32:08| Finished rebuilding storage from disk.
> 2007/07/05 13:32:08|       618 Entries scanned
> 2007/07/05 13:32:08|         0 Invalid entries.
> 2007/07/05 13:32:08|         0 With invalid flags.
> 2007/07/05 13:32:08|       618 Objects loaded.
> 2007/07/05 13:32:08|         0 Objects expired.
> 2007/07/05 13:32:08|         0 Objects cancelled.
> 2007/07/05 13:32:08|         0 Duplicate URLs purged.
> 2007/07/05 13:32:08|         0 Swapfile clashes avoided.
> 2007/07/05 13:32:08|   Took 0.3 seconds (1887.1 objects/sec).
> 2007/07/05 13:32:08| Beginning Validation Procedure
> 2007/07/05 13:32:08|   Completed Validation Procedure
> 2007/07/05 13:32:08|   Validated 618 Entries
> 2007/07/05 13:32:08|   store_swap_size = 3512k
> 2007/07/05 13:32:08| storeLateRelease: released 0 objects
>
> Thank you very much in advance for your help!
>
>

Reply | Threaded
Open this post in threaded view
|

Re: suqid proxy and localhost problem

Zbigniew Szalbot
Hello,

On Thu, 05 Jul 2007 09:37:29 -0300, Isnard Jaquet <[hidden email]>
wrote:
> Hi,
>
> I don't think I understand what you mean. Are you trying to connect to
> port 80 of your proxy? Is that it? Is apache installed and running (on
> port 80)? If it is, put the ip address of it in the exceptions list on
> your browser or disable the proxy from it when trying to connect to the
> apache on your proxy server.

Yes, sorry - I mean I could not connect to Apache on port 80 for that box.
Your advice is all I needed. Added that IP to the exceptions list in the
browser and works well. Thank you to all of you for being so helpful!

--
Zbigniew Szalbot